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Getting started with BRAHMS  
  

Updated March 2024 

  
  

This guide provides a rapid walk-through of key functions and features available in BRAHMS. 

No previous experience using the software is expected.    

  

The larger BRAHMS manual covers all aspects of system operation including administration, 

configuration, connections to data stores, import and export, Rapid Data Entry, editing, 

report design, image management and mapping.  

 

The examples in this guide mostly refer to the demo conifer database but you can use 

another database as available. You can also request a quick migration of your own data, 

free of charge. 

 

Mostly, this guide does not focus on functions that apply to specific modules (for example 

those that work with museum collections, botanic gardens and seed banks). Rather, it deals 

with functions that apply to all modules. Having said that, the conifer demo database is 

‘preserved specimen’ oriented. 

  

If you have not installed BRAHMS or connected to a database, refer to the installation guide.  

 
 

For licensing enquiries, contact brahms@innovation.ox.ac.uk   

To obtain an evaluation version, visit https://herbaria.plants.ox.ac.uk/bol/brahms/software/evaluations   Technical 

enquiries, contact brahms@biology.ox.ac.uk    
 

  

  

  
BRAHMS © Copyright, University of Oxford, 2024. All Rights Reserved  
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Introduction 

BRAHMS is a scalable management system for preserved and living natural history collections as well 

as those undertaking floristic or taxonomic research. Its development is based on almost 30 years of 

database implementation.  It manages biodiversity data. 

For researchers, collection managers in museums, botanic gardens, herbaria and seed banks, 

BRAHMS helps to optimise the value of your data for management and research, increasing outputs 

and productivity.  

 

Data integration for research and collection management is a key objective with BRAHMS.  

  

Some database project examples:  

• Manage your herbarium, grasshopper or beetle collection.   

• Develop a comprehensive botanic garden or seed bank management database.   

• Create a catalogue of fungi.   

• Produce an annotated checklist for any specific area or region.   

• Create an online portal to search and display your data, images and maps.  

• Help prepare a monograph for a taxonomic group.   

•  - or all of these combined as part of a larger, integrated natural history database. 

Online training videos can be found on: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos  

 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos
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Building a BRAHMS database  

Introduction  

The development of a well organised database is often a key activity for curators, collection 

managers and researchers. The strategy adopted varies depending on your resources; the 

amount of data you have; and your overall objectives. In all cases however, the paths to 

successful database development are similar.  

Hardware  

For individual researchers running their own show, the software and the database will most 

likely be installed on a personal computer running Windows or on a Mac with Windows 

emulation. Aside from having sufficient disk space and as much RAM as possible (8GB or ideally 

more), there are no special requirements other than that the .NET version is sufficiently up to 

date. Performance is broadly related to how well resourced your infrastructure is.   

For institutions with large collections and potentially many simultaneous users, the database 

will be stored on a server. The server will need sufficient disk space and adequate RAM.  If you 

try to run any large database on an inadequately resourced server, performance may be poor.   

The BRAHMS software itself will either be installed on individual client workstations or in a 

shared location. You can also have a set up with remote server log in by users located on 

different sites. Cloud solutions are ideal for BRAHMS and if you are interested to explore this, 

contact the BRAHMS project. On larger networks, the set up you adopt will be fine-tuned to 

achieve the maximum performance, a specialised IT task not further discussed here.   

Cutting corners on hardware set up is something of a false economy when it comes to 

establishing a healthy database environment, all the more so when there are large databases 

and many users.  

Data migration    

You may have data in BRAHMS v7; in Excel; in Access; or in another bespoke database package. 

These data can be migrated into BRAHMS v8. Databases in BRAHMS v7 can be automatically 

upgraded to v8. Contact the BRAHMS project and we will do this for you. Data in Excel can 

usually be imported via the BRAHMS Rapid Data Entry module (RDE) component. Data held in 

other packages will require some form of migration input.  

Optimising data capture  

Data entry efficiency can be optimised for all projects. While smaller number of records can be added directly 

into BRAHMS, the recommended procedure for larger scale data capture and processing data backlogs is to 

use Rapid Data Entry (RDE). A section on using RDE is included in this document and in the main manual. 

Mastering RDE is easy and certainly worthwhile when you are processing a lot of new data. 

 

Query and analysis  

BRAHMS is provided with flexible query functions. You can query your data on any combination 

of fields and save complex queries for future use. There are also numerous further features for 

viewing, sorting, filtering, calculating and analysis. Data grids are virtualized, ensuring they are 

fast even if you are working in tables with millions of records.  
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Exporting and reporting data  

All data can be exported to Excel or CSV – and all such exports respect your currently selected 

column views, applied filters and sort order. You can also export data as Darwin Core 

Archive (DwC-A) format. You can also export your entire database to XML files.  

Aside from using the basic data export options, you can create report templates for lists, labels, 

loan forms and others. Learning to design cool report templates is one aspect of mastering 

BRAHMS where users can go the extra mile, delving into the report design options as laid out, 

for example in https://www.stimulsoft.com/en/documentation . The BRAHMS guide has a section on 

report design and we also have a few videos: https://www.youtube.com/user/StimulsoftVideos . 

Mapping and map point editing 

Procedures for creating maps using different GIS options such as QGIS are reviewed in the 

manual map section. Bear in mind that if you are online, you have access not only to the in-built 

mapping tools but also the map point location editor. One of the handiest features in BRAHMS 

is the ability to view data records and map points together, dynamically linking these to 

highlight the current data record, and respect filters.  

Getting more detail on some of the key BRAHMS modules 

The following sections can be found in the main BRAHMS guide:  
https://herbaria.plants.ox.ac.uk/bol/content/software/v8/BRAHMS_Manual.pdf 
 

• A closer look at taxa and related data  

• Collection Events 

• Museum and herbarium specimens 

• BRAHMS for Botanic Gardens 

• BRAHMS for Seed Banks and Seed Conservation Projects 
 

 

  

https://www.stimulsoft.com/en/documentation
https://www.stimulsoft.com/en/documentation
https://www.youtube.com/user/StimulsoftVideos
https://www.youtube.com/user/StimulsoftVideos
https://herbaria.plants.ox.ac.uk/bol/content/software/v8/BRAHMS_Manual.pdf
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Register and log into the demo database  

If you haven’t installed BRAHMS and/or do not have a link to the conifer database or any another 

database, refer to the installation guide: 

https://herbaria.plants.ox.ac.uk/bol/content/software/v8/BRAHMS_installation.pdf    

If you do not have a BRAHMS licence key, please register here: 

https://process.innovation.ox.ac.uk/software/p/14165t/brahms-trial/1 or write to 

BRAHMS@biology.ox.ac.uk. 

There are 2 main ways you can register and log into the conifer demo database.  

Method 1: Download the conifer database in SQLite 

• From https://herbaria.plants.ox.ac.uk/bol/brahms/support/conifers choose the option ‘Download the v8 

SQLite demo database’. This will download coniferdbv8.zip. Open the zip to create a single file called 

brahms.db. 

• If you don’t have a folder Document\BRAHMS, create it. If logged in before, the folder will exist. 

• Copy the brahms.db file to your Documents BRAHMS folder. If that file already exists in that folder, 

overwrite it with your downloaded file. 

• Log into BRAHMS choosing the default Personal data location. Any problems, refer to: 

https://herbaria.plants.ox.ac.uk/bol/content/software/v8/BRAHMS_installation.pdf 

• When you log in, choose BRAHMS Authentication. The default conifer database username is ‘Demo’ and 

the password is ‘demo’. The password is case-sensitive. 

 

Logging in to the Personal Data Location using BRAHMS authentication. 

Method 2: Download the conifer XML folder 

• From https://herbaria.plants.ox.ac.uk/bol/brahms/support/conifers, choose the option ‘Download 

the demo database in XML format’. This will download a zip file called ‘conifer_xml_feb2023.zip’ or similar. 

Expand the zip to a new folder. This will result in a series of XML files.  

• Log into BRAHMS choosing the default Personal data location. Any problems, refer to: 

https://herbaria.plants.ox.ac.uk/bol/content/software/v8/BRAHMS_installation.pdf 

• In a new BRAHMS system, this is an empty data store. When you log in, you can choose Windows 

authentication. The first log in to a data location will auto-add the log in you first use. This is something you 

can alter later on. 

• As initially, the data location has no registered database project, the Database Project Manager auto-

opens. Select the Import option, navigate to the conifer XML folder and select the XML file listed by 

BRAHMS - DatabaseProject.xml. This will then trigger the import of the conifer database to your personal 

data store. 

Note – the same XML folder can be imported into PostgreSQL and MSSQL SERVER data stores. 

 

https://herbaria.plants.ox.ac.uk/bol/content/software/v8/BRAHMS_installation.pdf
https://herbaria.plants.ox.ac.uk/bol/content/software/v8/BRAHMS_installation.pdf
https://process.innovation.ox.ac.uk/software/p/14165t/brahms-trial/1
mailto:BRAHMS@biology.ox.ac.uk
https://herbaria.plants.ox.ac.uk/bol/brahms/support/conifers
https://herbaria.plants.ox.ac.uk/bol/content/software/v8/BRAHMS_installation.pdf
https://herbaria.plants.ox.ac.uk/bol/brahms/support/conifersC
https://herbaria.plants.ox.ac.uk/bol/content/software/v8/BRAHMS_installation.pdf
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Task 1: Some setup options 

• Select System > Options  

On networked systems, the ability to edit set up options will be restricted – depending on your 

user permissions. However, as a personal user logged in with Admin rights, you have access to 

all options. A few are discussed here to get you started.  

 

• Choose Taxa to configure how calculated taxa names appear.  

• Select Grid Options to set how data grids appear and to set Tag colour options. 

• Select Background Image to personalise the application.  

There are many other settings, e.g. to configure plant numbering and Rapid Data Entry features 

– these can be checked out later on, as appropriate for your project. 

 

Picking on one example on the Taxa tab, you can control how the calculated field #Full Name appears in your system. 

Some projects prefer to see all authors, others not. Bear in mind, when creating reports, species names, with or without 

authors, can be formatted in any way you like. 
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Task 2: Adding a user account and setting permissions  

Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#useraccount  

Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#userpermissions  

Adding users and setting permissions is described in detail in the BRAHMS guide. You can add users 

with BRAHMS, Local Windows account or Domain account authentication. Users can be assigned 

access and permissions to one or more databases.  With Windows or Domain accounts, users will 

not require any additional password to log into BRAHMS. 

In this example, add a new BRAHMS authentication user and assign this user permissions.  

• Log into the demo database and select System > Manage Users and Permissions.  

• Choose the User List option above the grid (or use Add on Data Tools).  

• Select New User > Add BRAHMS User adding the Username, Password and ‘Known As’ name. Do not set 

the user as an Administrator.  

 

• Select Create this User and follow through with Add this user. 

• Close the user form and select the new user on the User Management data grid.  

• Then select the Access/Permissions option.   

 

After editing some settings on the General and Specific Action tabs, assign new permission role name (here 

‘Volunteer’) and use the Apply As option to save the settings and assign this Permission Set to the current user.  

In practice, a larger project may have many different permission sets to apply to different users.  

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#useraccount
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#useraccount
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#useraccount
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#userpermissions
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#userpermissions
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#userpermissions
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Task 3: Opening tables and using data grids  

Working on a small or low resolution screen?  

If you are working on a small screen and/or have the screen resolution set to lower values, the 

toolbars may collapse as shown in the screen below. 

 

Note that the Calculate and Import/Export toolbar options have collapsed. In these cases, you need to click on 

the larger icons to expand the options. 

 

 

The same toolbar on a higher resolution screen. 

  

Opening and closing tables in data grids  

By default, BRAHMS uses data grids with context sensitive toolbars to browse, locate, sort, edit, query and 

analyse your data. Data tables are opened using a single click on the selected menu entry.  

• On the Taxa menu, click once on Families.   

 

When a table opens, the toolbar changes to Data Tools – this is where most of the general 

processing options are to be found. For Taxa specific tools or if you want to open another taxa 

table, return to the Taxa menu.  

• To close the table, select the X next to the opened table name.  

  

Closing a table using the X mark next to the table name.  

• Alternatively, to close tables, use Alt+X. Function keys such as Alt+X are listed using Shift+F1 when in any 

data grid. A grid must be active to do this.  Refer to the section on navigation and function keys.  

 

Opening multiple tables  
See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#multiple    

You can open and utilise different tables at the same time. The task here is to open the main 

family, genus, species and collection events tables.  

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#multiple
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#multiple
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#multiple
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#multiple
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• On the Taxa menu, click once on Families.   

• Return to the Taxa menu and click on Genera. Repeat this now for Species. Note that each time you open 

a table, the Data Tools toolbar is activated – so you have to return to the Taxa menu.   

• Finally, on the main menu, select Collections and choose Collection events and then Specimens. 

 

 

Each table has a tab which can be selected to view the data in that table.  
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Task 4: Docking tables, forms and other windows 

See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#multiple    

Video:  https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#opendocklink    

To view two or more of the tables opened in the last exercise at the same time, use the 

docking features. Tables can be detached from a centrally docked position and docked to the 

side, above or below another table – or dragged to a different monitor. Forms, images, 

external web sites, maps, query tools and others are all dockable.  

Positioning tables and other items takes a little practice - there are many potential docking 

arrangements. The tasks here assume one monitor – but if you have two or more, take 

advantage of these to display tables and other screens fully undocked.  

• Drag table tabs to undock them. Initially, it can be a little tricky to grab the tab correctly. When you drag 

any table to undock it, a series of yellow ‘docking boxes’ appear.   

• Drop the table on one of these docking options – the central box redocks the table as it was.  

• As a first try, drag the genus table and re-dock this by placing and releasing your mouse pointer over one of 

the yellow docking points. Repeat for the species table.  

   

Here the genus table has been undocked and is floating above the other tables. And the species table is 

about to be docked to the right.  

• Repeat this with the collection events table, docking elsewhere or moving it to a different monitor.  

  

The various tables rearranged with collections events dragged off the main application  

  

The yellow docking points appear when you drag a table from a docked position.. Docking options vary 

depending on the windows opened. Some experimentation is required.  

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#multiple
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#multiple
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#multiple
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#multiple
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#opendocklink
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#opendocklink
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Map screen undocked and dragged to separate monitor. In this example, data records have been tagged using different 

colour symbols, these reflected on the map.  A column summary on the Tag column is also active and docked to the right of 

the main grid.  

  

  

Left monitor with genus and species tables docked next to the TROPICOS Weblink. The collection events table is shown in the 

lower small screen and an ArcGIS map with Google Images on the left monitor. The events table is set to update to the 

selected species record – together with the map and the images.   
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Task 5:  Short cut keys (F-Keys) 

It may be useful to print this page at it lists all the handy shortcuts keys to help speed up activities across all 

database tables. You can also open this list using Shift +F1 from any active grid. 

Function keys  

 

           

  

Column Help 

 

Using Ctrl+ I on any column open, you can see the properties of that column 

 

Also, assuming you have database permissions, you can use Edit Description to add/edit the descriptive help 

text for that column (in any language). 
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Task 6: Data grid navigation, F-keys, Zoom, Context menu  

Navigation  

There are a few tricks to learn to move efficiently between columns and rows in BRAHMS data 

grids. BRAHMS draws data from your data store into the grids and presents these data with low-

lag data virtualization, storing as much data as possible in memory.  As you scroll up or down, 

the system retrieves the relevant data to memory and refreshes the opened grid.  

• Close all the tables used in the previous task.   

• Select Collections > Collection Events to open the events table.  Activate the grid by clicking in any data 

cell. The default mode for data grids is read-only mode, nothing can be edited.  

Action in non-edit mode  Keys  

Move to the next / previous column  Right / Left Arrow  

First/Last column  Home / End keys  

First/Last row  CTRL Home / CTRL End  

Next /Previous row  Down / Up arrow  

Scroll up and down  PgUp / PgDn  

Select or activate a column or cell  Click in the cell  

    

Action in edit mode  Keys  

Move to the next / previous column  TAB / Shift TAB  

Next /Previous row  Down / Up arrow or use Alt+Arrows in memo or numeric fields  

  

Function keys  
The list of available keys is provided in a previous section. If you have not printrd out the list, you can open 

using Shift+F1.  Some examples: 

• Press F6 several times to tag a few records. Pressing F6 on the same records will un-tag them.  

• Press Ctrl+T to set a filter on the tagged records.  

• Press Ctrl+F11 to remove all filters.  

• Press Ctrl+E to enter edit mode. Ctrl+E again to exit edit mode. 

• Press Alt+X to close the current table. 

 

Record Zoom to sum record and to quickly go to a column  

The record Zoom function is a great way to summarise and view the current record in any table – but you can 

also use it to navigate to a column.  

 

Double-click on the Zoom field header name e.g. ‘# Full Name (HTML) to go to that column. If it is not visible, it will be made 

visible.  
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Using a right-click on data grids for context menu 

Right-clicking on data grids opens up a short-cut menu to widely used options. 

 

The functions offered here are all available on the main toolbar. Most have shortcut F keys. 
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Task 7: Column Manager   

Video:  https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#columnviewvideo    

Selecting fields to view 

When you open a table, the default data grid columns will be visible. You can adjust and save 

new column views using the Column Management options. This applies to all tables. Selecting a 

particular set of visible columns is a handy way to view selected data and speed up specific 

editing tasks.  

• Select Collections > Collection events then Grid Tools > Manage Columns. You can also use F8 or a right-click 

on the data grid to open the Column Manager. In practice, using F8 is usually the fastest way to open the 

form. 

 

The Column Management Tool allows you to select visible columns. You can use the Filter option at the top of this form to 

locate columns by name. Note that there are options to move the field positions. 

Another way to adjust visible columns and field order is to right-click on any of the column headers. This opens 

a dialogue form with options to show hidden columns and alter the column order. You can also drag column 

headers to change order and size.  And here’s another handy way to hide columns:  

• Click anywhere on the Family table to make it the active table. Now click in a field you want 

to hide.  Select the Grid Tools tab and then Hide Current – this hides the selected field.  

  

 

Saving a view 

You can save a view using Save layout on the Column Manager form itself or from the Grid Tools toolbar. This 

will create a small data grid view file with a file extension ‘.dgv’. The file is saved to your 

Documents\BRAHMS\Columns folder. You can create as many views as you want, choosing the view using the 

Layout dropdown. You can share views with all user on your BRAHMS database by copying the .dgv file to the 

designed Shared folder as specified in your set up options. 

 

Deleting a view 

Deleting a .dgv file from the Columns folder will remove it from your list.   

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#columnviewvideo
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#columnviewvideo
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Task 8: Querying the database 

 

Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#datagridfilters   

Using the data grid filter row  
See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#explore  

• Open the main file collection events table using Collections > Collection Events.   

• Enter values into the yellow grid filter row as shown below. You can use operators *, =, <, >,<=, >=  and 

combine values using capitalized AND/OR statements. You can use keywords NOT and NULL.  <> means 

not. Thus, adding <> NULL shows non-empty records. The grid filter bar is an efficient way to apply single 

or multiple filters and locate records. Note that you must use capitalized key words such as AND and OR. 

  

Using the grid filter row, you can add values to as many columns as needed. For text strings, the default filter mode is 

‘includes’. Use = to make a precise match.  

  

An example in the Month field using the operators < and >. 

• You can use * to select ‘starts with’ and ‘ends with’, thus:  

  

Setting a filter where collector name starts with ‘ter (left) or includes ‘ter’ (centre) and right, where the genus ends ‘illa’.  

Using Selection and +Selection  

You can set filters on current cell values using the Selection and +Selection options.   

• Open the main file collection events table using Collections > Collection Events.  Set a filter on a cell 

value by clicking on the value and then the Selection toolbar. This option overrides any previous filters.  

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#datagridfilters
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#datagridfilters
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#datagridfilters
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#datagridfilters
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#explore
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#explore
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#explore
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• You can add multiple cell-based queries using the +Selection option.  As soon as you select Selection 

rather than +Selection, the filter will be again restricted to a single value.  

 

Using the Selection options on the Filter dropdown. On the same dropdown, you can use the Filter info option to check filter 

settings. 

 

 Checking filter settings  

  

The main Query tool 

Using the main query tool , you can create and save commonly used queries. Refer to the Find, Filter and 

Query section of the main guide https://herbaria.plants.ox.ac.uk/bol/content/software/v8/BRAHMS_Manual.pdf 

The Query tool can be a faster way to run queries, especially in large databases and where you are using > 1 query 

parameter. This is because the query is sent to the database in one go rather than as separate queries (as is the case with 

the grid filter row). 

 

 

https://herbaria.plants.ox.ac.uk/bol/content/software/v8/BRAHMS_Manual.pdf
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Task 9: Calculated fields 

What are calculated fields? 

Many BRAHMS tables have fields which are calculated. These usually start with #. Many are numeric totals. 

Most of these fields are not automatically updated – there is a special recalculation tool used to update them. 

This tool can be auto-run overnight using a Windows Task but this Task is not further discussed in this guide. 

Numeric totals examples: 

• Most tables: # Images - total number of images linked to the current record. 

• Species table: # Collection Events - total number of collection events per species. 

• Country table: # Species – total number of species collected per country. 

Text examples: 

• Species table: # Full Name – the full species name calculated based on your set up options. 

• Species table: # List Syn. A-Z – a list of synonyms for the current species record. 

• Gazetteer table: # Full Gazetteer – a collation of text fields from country to location name. 

Updating calculated fields 

To update all # Calc Fields for your database: 

• Select Management > Recalculation Scripts 

• Then select Run All which will update # Calc Fields for the entire database. This process may take a few 

minutes in the conifer demo database. 

 

Use Run All to update all Calc Fields in your database.  

Viewing #Calc fields 

Most calculated fields, by default, are not visible in the tables. You need to select the ones you wish to view in 

the data grids.  

• Select Taxa > Species and then you can open the Column Manager (as in the previous task) to add one or 

more # fields. 

• You can also use # Calc Fields on the Data tools toolbar to view all # Calc Fields per table (on/off toggle). 

 

Using a grid row filter on a #Calc Field in the species table – showing species that have > 100 collection events. 
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Task 10: Sorting Records 

See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#sorting  

Sort on single or multiple data grid columns  

If column sorting is enabled, tables can be sorted on single columns by clicking on the column header, Shift 

Clicking on multiple column headers … or using the Sorting Tool. To use header-click sorts, make sure this 

option is enabled by setting Enable Header Sort on the Grid Tools toolbar. You can also set this on by default 

for all tables in System > Options > Grid options. 

 

• Select Taxa > Genera to open the main genus table.  

• Click once on the Family column header to sort A-Z. Click the same column header again to sort Z-A. 

Click a third time to remove the sort.   

• You can combine as many columns as needed using Shift Click on columns headers.  

 

Saving complex sort commands  

Using the Sorting tool, you can add fields of any type to create complex sorts. You can save these sorts using 

the Save option provided.  

 

Using the sort form, any combination of character, numeric, date and logical field can be selected to sort your records. 

Complex commands can be named and saved for future use.   

  
  

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#sorting
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#sorting
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#sorting
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Sorting collection events by collector and number  

Collection event field numbers are alphanumeric and thus, by default, sorting the field number column AZ 

gives an incorrect sort order.  

  

As can be seen here on the left, sorting these Wilson, EH collections on Field Number gives a bad result. This is resolved 

using the calculated field # Field Number (sortable) shown on the right which pads the number field with zeros.    

• To display this field, select Grid Tools > # Calc Fields  

• You could now sort the collection events table on the Collectors + Field Number (sortable) fields but in 

reports, still refer to the column Field Number. NB If you do not see data in the sortable field number 

field, use Data Tools > Calculate > Recalculate.   

In reports, you can auto-sort on the Field Number field avoiding the need to use the above calculated field. The 

procedure is explained in https://herbaria.plants.ox.ac.uk/bol/content/software/v8/brahms_manual.pdf 

section Reports and Report Templates > Sorting alphanumeric fields numerically in reports. 

  

Date sorting  

Records can be sorted on date fields. For example, you can sort on the audit fields Created By, Created On, 

Last Modified By and Last Modified On and such sorts are useful for a variety of purposes.   

When you add a new record, the data grid is auto-sorted on the Created On field. But you may find it useful to 

sort on this field (click on field header) at other times, perhaps in combination with other fields.  

For example, to view records most recently added, you can sort on Created On, clicking the column header 

twice to bring the most recently added record to the top of your data grid.  

If you want to sort collection events by date, sort on year, month and day in that field order, shift clicking on 

fields for multiple selections.  

  

You can also easily sort on the Last modified date, or using the dropdown on that toolbar option, Date Created. 

  

  

  

  

  

     

https://herbaria.plants.ox.ac.uk/bol/content/software/v8/brahms_manual.pdf
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 Task 11: Tagging functions 

See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#tagging  

Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#tagsandmaps    

Tagging records 

Tagging refers to the addition of a single character to the TAG field. This field is available in all tables in the 

first column. Tagging has multiple uses throughout BRAHMS with record selection and grouping. While the 

default tag symbol is *, you can tag records with different symbols or numbers. Each of these can be assigned 

a colour.  Tags are user-specific, thus one users’ tags do not interfere with those of another working in the 

same table.  

         

 

• Select System > Options > Grid Options to edit the default colour options.  

• Clicking on the Tag option on the Data Tools toolbar (or using F6) adds the selected symbol to the TAG 

field.  

Tag related options 

The Tag toolbar dropdown provides a list of handy tagging options:  

Transfer tags Copy tags to parent or child tables. 

Count tags  A count of all tagged records.   

Show tagged only Show only tagged records *  

Tag Random Tag a specified number or % of records. 

Tag all  Tag all records in table – respecting any filters  

Clear all grid tags  Remove your tags from all tables – does not respect filters  

Clear current grid tags  Remove your tags from the current table – respecting current filters  

Invert tags  Tagged records are set to no tag; records that had no tag are tagged *  

Tag Groups Create a saved group of tagged records. 

Tag with  Choose tag symbol from list.  

  

  

Records tagged with a variety of symbols.  

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#tagging
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#tagging
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#tagging
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#tagsandmaps
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#tagsandmaps
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#tagsandmaps
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Tag Groups 
By using Tag > Tag Groups, you can create and save ‘groups’ based on your tagged records. Tag groups can be shared with 

other users. 

 

Some sample tag groups in the species table. One of these groups (Doubtful entries) is shared and thus can be seen by other 

database users. 

Tag Transfers 

Tag > Transfer tags provides options to copy tags to related tables, either up or down a data hierarchy. This tool 

has multiple applications throughout BRAHMS. 

 

For example, in the species table, tagging down would copy tags to child records including collection events and living 

accessions. By select the ‘Tag all child records’, the tags will also be copied to the plants, specimen and determination history 

tables – and any others in the hierarchy. 
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Task 12: Summaries by data column 

See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#colsum  

The column summary option lists the different values in the selected column, providing the total number of 

records per value.   

Summary for single columns 

• Select Collections > Collection events.   

• Locate and click in the column # Full Name and then select the Summary option on Data Tools. If you do 

not see the summary option, refer to the section on small screens.  

 

Here, the summary shows the number of collection events per species. Moving to a different column will update the 

summary, assuming Auto-update on column change is selected. Click on the summary columns to sort by field name or 

count. 

Apply filters on one of more values 

  

 

The summary option can also be used to apply filters on one or more selected values. You can save a summary list to 

Excel using the Export option provided on the summary form.      

  

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#colsum
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#colsum
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#colsum
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Multi-column summaries  

You can also create summaries on 2 or more columns as selected from your visible columns list. 

As an example based on data in the conifer training database, you may want to know how many collections 

were made per country per family. 

• Select Collections > Collection events.   

• Make sure the columns you need are visible. If not, use the Column Manager to enable them. 

• Select Summary (+) on the Data Tools toolbar. 

• Using the options provided, add the columns that you want to use to calculate the totals. 

• Select Load Summary. 

 

 

The list created can be sort and filtered. In this example, the China filtered list is sorted by total collections per family. 

 

 

In this example, the number of collections per genus per year per region for New Zealand is calculated. 
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Task 13: Saving data to Excel  

See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#exporting   

Data are easily exported to Excel /csv spreadsheets using the Export Tagged option on Data Tools. Exporting 

works only with tagged records. Exports respect applied filters, your currently selected column view and any 

sorting you may have applied. 

In this task, export specimen data from BRAHMS, sorted by family and species name, restricting the export 

to some columns and the filter selection to holotypes. Adjust filters as necessary, depending on your data. 

• Select Collections from the main menu and choose ‘Preserved Specimen’ using the Category drop down.  

• Select Specimens to open that table.    

• Now press F8 or select Grid Tools > Manage Columns and here you can remove any columns you don’t 

want to export and sort the table as wanted.   

• Locate the Type Category column and enter ‘holo’ in the filter bar to apply a filter on Holotypes.   

• Select Tag > Tag all – this will tag records within your filter group. 

• You can now use the Export Tagged option to save the tagged records. If you do not see the Export 

option, refer to the section on small screens.  

 

Exporting tagged records to Excel. 

You can list all saved files using the View option on the Export Data toolbar section.  

 

    
  

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#exporting
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#exporting
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#exporting
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Task 14: Adding and Deleting records 

Adding records 

New records are easily added to your database. If you are working on a non-personal database, you may need 

permission to add/edit data in different tables.  But if you are logged in as Admin level to the training 

database, you will have full access to all functions. 

Adding records efficiently in bulk is a separate process that uses the BRAHMS module called Rapid Data Entry 

(RDE). This is discussed elsewhere. This section looks at adding records one by one. 

When you add a new record, the record will appear at the top of the table. The ‘Added On’ and ‘Added By’ 

database audit fields are updated for all new records. 

• Select Taxa > Species to open the main species table.   

• Select the Add option on the main toolbar. The system will automatically go into Edit mode. 

Note: if you are not in Edit mode, all records will be read-only. 

• When you add a record to the species table, the Genus Selector form auto-opens. This is because a genus 

name (even if indet.), is required. If the genus you want is not yet stored in your genus list, you will need 

to add that first using Taxa > Genera. 

 

 

When you add a genus name to the species table, the family and any higher level classification is also added. 

• You can now proceed to add in more data to the new record – for example the species name itself and 

infra names if you have.  

• Using the toolbar Form option, you can add and edit data using the form rather than the grid. Forms are 

further discussed below. 

The same procedures can be used to add records to all tables. There will be some variations as required fields 

will vary from table to table. 

Deleting records 

In all BRAHMS tables, record deletion is a 2-stage process. 

• Locate a record that you want to delete – it might be the record you have just added. 

• Press the DEL key or click on the X Delete toolbar. Note that * is added to the DEL field and the record 

goes to strikeout font. All tables have a DEL field. 

• The record is not yet deleted – it is only marked for deletion. You can reverse the above by removing the 

DEL field * manually, or by clicking again on DEL or the X Delete toobar option – when on the deleted 

record. 

• To finally delete the record and indeed any other records that have the * in DEL, on the toolbar, on the 

toolbar, select Delete > Remove records marked for deletion. 

If you delete a record that has children records – e.g. a species with linked collections, BRAHMS reports the 

consequences. For example, you may be warned that the species you want to delete has linked collections. 
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Task 15: Using forms for data entry and editing 

Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#speciesformvideo    

Forms are provided for most tables. They can be used for editing and often provide additional options 

to view and cross-reference data in other tables. Forms update as you move to new records. They can 

be undocked and re-sized. If you are not in Edit mode, data cannot be edited/saved.  

       

The form icon indicates if you are in Edit mode or not.  

Most forms have the option to edit data and then Save or Cancel the edits made. Once any edits have 

been made, the form is given a red surround.  

• Select Taxa > Species and then select the Form option on Data Tools.  

• Review the various form tabs, moving through grid records to update the form data.  

   

Data can be viewed and edited using grids or forms. Forms can be resized, docked or dragged to separate monitors.  

•  To hide unwanted fields on the species form, select System > Options > Taxa > Species Form and 

here you can choose to hide unwanted species epithets. 

  

Summary of collections displayed from the main species form. Move to a new species in the grid to update the form.  

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#speciesformvideo
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#speciesformvideo
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#speciesformvideo
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Task 16: Using field lookups 

When editing data, the challenge is to maximise efficiency. You can use function keys; some handy tools 

such as value merging; and using Lookups. Lookups minimise typing and help standardise your data.  

There are two main categories of Lookup. Those that link to other main tables in BRAHMS such as species, 

place names and collection events. And those for all other fields such as habit, IUCN category and taxon 

status. These may be standard or custom fields.  

Activating lookups 

In this guide, you have already used a lookup when adding a new species record as this action opened the 

Genus Selector. You can activate the Genus Selector (and any other lookup in an appropriate field) by:  

▪ Clicking on the Lookup option on the main toolbar.  

▪ Pressing F9. 

▪ Typing Ctrl+L.  

▪ Selecting Lookup on the Right-Click context menu. 

Using standard lookups 

• Select Taxa > Species to open the main species table.  Make sure you are in Edit Mode.  

• On any record, click in the genus field and press F9 or use one of the other lookup options. This will 

open the Genus Selector allowing you to change the Genus name of the current species. 

 

Another example: 

• Select Collections > Collection Events to open that table.  Make sure you are in Edit Mode.  

• On any record, click in a geographic field such as Locality Name and use a lookup to select a place name. 

• In the map field Latitude, use a lookup – this will open the Map Point Editor. 

 

Registering lookup values in the central Lookup Fields table 

Lookup values for all fields that have lookup capability (excluding those that link to other BRAHMS tables 

such as the genus name example above) can be registered manually or by importing from an Excel list. 

Lookup fields can be single or multi-value lookups. Here’s an example with IUCN Red List categories: 

 

Lookup for IUCN categories  

If you are using the conifer demo database, the field IUCN is probably already registered as a lookup called 

IUCN. As a useful exercise, you can delete this lookup field and its values – and then re-add it. 

• Select Management > Lookup Fields. Locate the field IUCN. If you press the option Show Field Lookup 

Values, you will see the list of IUCN categories listed. 

• Assuming the field is present, mark this look entry for deletion and then delete the record. Refer to the 

general section on deleting records for help. 

• Now select Taxa > Species.  Locate the field IUCN Red List. If is not visible, switch it on using the Column 

Manager (F8). In the conifer database, Red List values (EN, VU, CR, etc.) are already added for most 

accepted names. 

• In the species table, ensuring you have clicked in the IUCN field, select the main Edit toolbar dropdown 

and then select Edit lookup values… you will see how all of the existing values in the species table are 

listed on the left. You can use the options provided here to register some or all of the values as lookups. 

Once selected, close this form.  

• If you now move to Edit mode, you will see the IUCN field is a dropdown where you select a value. 

• If you now select Management > Lookups Fields again, you will see your newly registered IUCN lookup 

field. 
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Task 17: Create maps using the ArcGIS API  

See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#mapping  Video: 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#mappingvideo   

You can also map your data to ArcMAP, QGIS, DIVA, Google Earth and GeoCAT. These topics are explained in the manual. If 

you use QGIS, refer to the QGIS videos on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos.  

Internal mapper - advantages 

The in-built ArcGIS API provides a wealth of handy mapping features which you can take advantage of without 

installing any GIS software. You do need to be online.  Some advantages of the in-built ArcGIS tool:  * No 

installation required; * data points are highlighted on the map as you browse through your data grid; * clicking 

on a map point locates the grid record, an excellent way to locate errors; * maps are auto-updated as you 

apply grid filters; * calculation of Extent of Occurrence (EOO); * selectable base map including world imagery; 

* map tagged only or map all; * exclude cultivated records; * search maps; * save map as a png file and import 

to a document.   

• Select Collections > Collection events then select Maps followed by ArcGIS in BRAHMS.  

• Maps respect filters and, by default, will only plot tagged records.  

• To plot records, tagged or not, adjust the Tagged only option.   

 

In the above example, nothing is mapped because there are no tagged records and the option “Tagged Only” is selected. 

 

 

A map displaying all conifer collections. The setting here does not restrict to tagged records and a dark grey base map is 

selected. The current data grid record in Mexico is highlighted on the map with a yellow dot. 

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#mapping
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#mapping
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#mapping
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#mappingvideo
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#mappingvideo
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#mappingvideo
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#mappingvideo
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Here, a filter set on New Zealand with the base map set to World imagery. The point colour has been changed and the 

current grid record is highlighted. 

 

Here the map toolbar options Draw Search Area and Search Map Area have been used. The records in the data grid have 

been filtered accordingly. 

• To add a map image to a document, you can select Map Screenshot on the map toolbar. This creates a png file which 

you can easily import to your document. 
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Task 18: Images and Documents 

See examples on https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#images   

Images 

Images can be linked to any record in BRAHMS. You can link multiple images to the same record. All images 

are listed in the central images table with their full pathname or web URL.   

Images may be stored in any location including media libraries and on the cloud. Read more about managing 

images in BRAHMS. You can store links to images using a URL – no need to have a copy of the image file.  

Images can be viewed from the main image file and/or wherever they are linked. As an example, you can link 

some images to a species:   

• Select Taxa > Species. On Data Tools, select Images… to open the Image Viewer.  

• You need to make sure you are in Edit mode.  

• Now, you can either use the Link … button or drag images to the Image Viewer.   

 

 

The Image Viewer has several handy toolbar options (Rotate, Zoom, etc.). You can also use F keys and your mouse to 

control the viewer, for example Shift + mouse wheel = zoom in/out around central point.   

Images can be transferred from Excel files to RDE and also from RDE to BRAHMS.  

Documents  

Multiple documents of any type can be linked to records in BRAHMS. This could be a Material Transfer 

Agreement; a collection permit for a specimen; a protologue description linked to a species; a sound file linked 

to an animal entry; or perhaps a video or slideshow linked to a botanic garden location.  

 

Linking pdf, docx, wav, pptx and xlsx documents to a species record. Media and documents can be opened using the Open 

option or double-clicking on the linked entry. 

• Select Taxa > Species and go to Edit mode. 

• To link a document, select the Documents toolbar option. 

• You can now link one or more documents to the current species record. 

 

  

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#images
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#images
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8#images
http://herbaria.plants.ox.ac.uk/bol/brahms/modules/images
http://herbaria.plants.ox.ac.uk/bol/brahms/modules/images
http://herbaria.plants.ox.ac.uk/bol/brahms/modules/images
http://herbaria.plants.ox.ac.uk/bol/brahms/modules/images
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Task 19: Merging values and records, using Find/Replace  

Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#mergevalues  

The tasks here demonstrate Value Merging and Record Merging.  

Value merging   

The Column Summary tool, as well as listing and giving a count for each different value in the selected 

column, can be used to quickly clean up data errors in non-relational, non-read-only fields. Value merging 

standardises different spellings of the same value in a column – and is a fast way to find and clean these 

errors. You can use value merging in any table – as long as the field is not read-only.  

• In the conifer demo database, select Geo > Gazetteer and select the Major Admin Name and/or Minor 

Admin Name columns.  

• Select the Summary tool on the Data Tools toolbar. Sort the summary record by values by click on the value 

header.  

• Tag the value(s) to be merged - then select the correct value by click on that record (no need to tag).  Use 

Merge to Selected to complete the task.  

 

In the example on the left, either spelling of Alpes-Maritimes may be acceptable but clearly, it is better to be consistent. 

The right-side example is in the Minor Admin Name column where you will find plenty of other entries to correct. Note that 

a grid filter has been used with the Minor Admin example to narrow down the summary entries.  

Record merging  

Record merging leads to 2 or more similar or identical records being merged into one record with a resulting 

deletion of the merged records. When record merging takes place, the system must ensure all child records 

are moved to the selected record. Record merging is used to clear up double (or more) entries of entire 

records – for example if you had two or more entries in the genus table for the same genus, both with linked 

species, you could not simply delete one, you would need to merge the records.  

  

The Merge records tool is found on the Edit dropdown.  

In this example, you can merge some gazetteer records.  

• In the conifer demo database, select Geo > Gazetteer and enter ‘jiang’ in the grid filter bar for the field 

Locality Name. Click on the column header to sort by name. Locate the entries ‘Nu Jiang - Qi Qu divide’ 

which is entered twice, slightly differently.  

• Tag the one you want to remove and then select the record to merge into. Then select the Merge option on 

the Edit dropdown on Data Tools.  

            

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#mergevalues
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#mergevalues
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#mergevalues
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Find and Replace   

On the Data Tools > Edit dropdown, you will find the Toggle Find/Replace Tool. Assuming that you have permission 

to use this, this tool provides an excellent way to tidy up and edit data in the active column. For example, in the 

conifer training database: 

Select Taxa > Species and ensure the TaxStatus column is visible. 

Click in that data column and then open the Toggle Find/Replace Tool on the Eidt dropdown. 

The task here is to replace the text ‘acc’ with ‘Accepted’ 

 

Fill in the Replace and With options. Optionally restrict the update to tagged records. Note that if you are replacing 

part of a string, you need to use % wildcards as described on the form help text. 

 

 

  

 

 

 

In this example, the calculated field shows 
each of these Nu Jiang  records has 1 linked 
collection event. These will be joined under 
the selected entry.  
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Task 20: Adding custom fields to BRAHMS  

BRAHMS databases and the tables they contain are provided with a defined structure. However, as well as 

defining the data columns that you choose to see in your data grids, you can add new data storage fields that 

are specific to your project.   

You can choose the field name, type and size. These custom fields become a permanent part of your database 

unless you subsequently opt to delete them. This also applies to RDE files.  

• Select Collections > Collection events - or another table if you prefer.  

• Select Grid Tools > Manage Columns.  

• Add one or more new columns using the Custom Columns tab. Field names can include spaces.  

  

The Column Manager form - options to add and edit custom columns are enlarged on the right side.   

On this form, you have the option to add new fields. If the field is of type Text and you set Max. Chars to NULL 

or 0, this creates a text field equivalent to a v7 memo field.  Using the Editor tab options, you can list and 

remove your custom fields. Field position can be modified using the buttons provided above the field list. You 

can also load existing field layouts, edit and save as a new layout.  

  

Custom fields appear in your main data grids, assuming they are selected for inclusion in your data grid view. They have a 

different font to standard fields.  
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Task 21: Register and open a Rapid Data Entry file  

Video: https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#labelstoppt  

While data can be entered directly into BRAHMS, RDE is recommended for entering larger numbers of records 

and also as a first step when importing or transferring data from other software packages such as Excel.  

   

RDE files are entirely separate mini SQLite databases linked to your main BRAHMS database. They provide 

portability and flexibility – optimising data entry and cleaning.   

You can store data in one or more RDE files and use these data to create summaries, maps, reports, manage 

images, and in general, use most of the BRAHMS tools and functions.   

This example opens an RDE file of specimen data prepared by John Wood (Oxford based botanist) from his 

field work in Bolivia.   

• First download the file RDE_Bolivia_JRIWood.zip and open the zip to the folder Documents/BRAHMS/RDE.  

This is the default location for RDE files.  The zip file includes an RDE file of specimens and a report template 

sample for labels.  

• Log into BRAHMS – choosing any project and select Rapid Data Entry > RDE File Manager. This will list any 

RDE files located in your registered RDE folders.  

• To open the RDE file downloaded above, double-click on the RDE manager entry ‘JRI Wood Bolivia’.  

• Explore this RDE file using the Summary option on Data Tools.  

 

An RDE opened with a column summary in the Family field. The summary shows the number of records per different family. 

Clicking in a different column will update the summary.  

  

https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#labelstoppt
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#labelstoppt
https://herbaria.plants.ox.ac.uk/bol/brahms/software/v8videos#labelstoppt
https://herbaria.plants.ox.ac.uk/bol/Content/Software/v8/JRIWood_Bolivia_specimens.zip
https://herbaria.plants.ox.ac.uk/bol/Content/Software/v8/RDE_Bolivia_JRIWood.zip
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RDE folders  

All users, regardless of their database role, have access to their default Documents\BRAHMS\RDE folder. 

Beyond this, non-admin and non-manager users need to be given access to folder(s) by the system 

administrator or database manager. 

  

RDE files can be stored in any registered folder. New folders are added using the Add option of the left panel. 

Administrators can register new RDE folders and assign access permissions to one or more non-admin level users.  
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Task 22: Import from Excel to RDE  

Data and images can be imported from .xlsx tables into RDE using the Excel Data Import Wizard. This allows 

you to match the columns in the Excel file to your RDE file. The matching between Excel and RDE columns can 

be adjusted as necessary to pull in as many fields as possible. This process also allows you to import data from 

custom fields – assuming the custom fields have been added to your RDE file. Fields in foreign languages can 

be mapped to the standard names. For example, your Excel table may store country names in a column with 

heading PAÍS or 国家 or PAYS. The task is to align this with the standard RDE field COUNTRY.  

This example uses collection data (species x locality) taken from museum specimens. But you could work with 

other data, for example, just a list of taxon names. If you do not have your own data to experiment with, 

download the sample Excel: 

https://herbaria.plants.ox.ac.uk/bol/Content/Software/v8/SampleExcel_RDE_Import.xlsx.   

• Select Rapid Data Entry > RDE File Manager then use the Add option on the Data Tools toolbar to create a 

new RDE file. Choose the Category ‘Specimens’ – and provide a file title. Enter Next. 

• If you want to add some custom columns to the RDE, use the options provided in the right-side panel. 

Knowing whether to add custom data fields requires some knowledge of what the default fields are.   

• When you Finish, the new RDE will be created and registered in your RDE manager.  

• Open the file by double-clicking on the record. Then choose Rapid Data Entry > Import from Excel…  

• Follow the Excel Data Importer steps as prompted.  

 

These screens show the matching process (left) and the data processed and ready to import to RDE. This may not be fully 

possible if the data are in the wrong format – but you will probably be able to get close. Data in different formats can be 

adjusted in Excel or processed after transfer to a custom field in RDE.  

 
If your Excel file includes image references as physical file names (path + file name) or URLs, these can be imported to and 

viewed in the RDE file. If there is more than one image cited in the same field, the entries should be comma or semi-colon 

separated or on different lines.  

   

  

Once the data have been processed by the Excel Wizard, you can then choose to transfer selected records or all the data 

into your new RDE file.  

https://herbaria.plants.ox.ac.uk/bol/Content/Software/v8/SampleExcel_RDE_Import.xlsx
https://herbaria.plants.ox.ac.uk/bol/Content/Software/v8/SampleExcel_RDE_Import.xlsx
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Task 23: Transfer RDE data to BRAHMS 

Introduction 

Data in RDE files can be easily transferred into BRAHMS. The transfer process starts with an analysis of the 

RDE data and will tell you about the new data you are about to import. Obvious errors will stop the process. 

The analysis phase does a lot of checking and in large files, it can take a while. 

 

Transferring from RDE into BRAHMS  

 

• On the main menu, select Rapid Data Entry and open the RDE table you wish to transfer to BRAHMS. You can 

optionally restrict the transfer to tagged records and if you wish to do that, tag the records to transfer. Otherwise, 

this is not necessary.    

• Back on the Rapid Data Entry menu, select Transfer RDE to BRAHMS…. and on the ‘Step 1: Run data analysis’ page, 

you can restrict to tagged if necessary.  

• Select Run Analysis – this will list the data that are new to BRAHMS and those that already exist. The report enables 

you to review the quality of the data. 

 

A part of an analysis report.  

• Now select Next to go to Step 2: Import the Data and select Import Data  

 

 

The data transfer from RDE to BRAHMS adds new records to your database as needed. 
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Task 24: Adding and editing map points  

You need to be online to use this feature. The map location editor can be used in RDE and in the main tables 

for any table with map points. You can use the map location editor to add a new map point or edit an existing 

one. The editor opens a map form which updates as you move through the data grid.  A right-click on the map 

resets the point position and either auto-saves this to the grid or awaits confirmation via the Save option.  

Select Collections > Collection events. 

• In the opened RDE file, select the Map point editor option on the map toolbar. In Edit mode, you can also use the 

standard F9 lookup from the latitude or longitude fields.  

  

Once opened, the location editor can be used to edit points and altitude in your data grid.  

 

The map location editor displaying the current point, set to Auto-save.  In this mode, a right-click on the map will update the Latitude 

and Longitude values in the data grid without using the Save option.  This example screen has no zoom and is displaying the entire 

globe.  

 

The same point displayed at a very different zoom level.  Right-click the map to edit point location.  
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Location editor settings  

Setting  Notes  

Base map  Choose base map that best suits the editing task in hand.  

Auto-zoom on/off  If selected, as you move to different records, the map zooms to the current point using your 

zoom scale setting.  

Zoom to marker  Zoom to current point based on your Zoom Scale setting.  

Zoom Scale  Choose the optimal zoom setting. Maximum shows a world map.  

Reset Zoom  Reset the zoom, if adjusted, to your current setting.  

Map units  Select the entry mode for manually editing data.   

Lat Long checked  Mark a record as ‘map checked’.  

Auto-save  If selected, a right-click on the map will adjust the point and save the map point change.  

  

 

Location searching 

The internal Map Point Editor, dynamically connected to your data grids, has a location search tool. Localities can be 

searched for by name or part of a name, adding a region or country to help improve the results listed. Clicking on the 

suggested locations list adds a blue suggestion marker to the map. A right-click on the map adds the map reference to 

the data grid.  

 

Using the location search option with the Map Editor. 
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Task 25: Reporting example 

NB: Before running the report sample, be sure to run through the task on #Calc Fields as it uses a calculated field. 

You can print reports directly from any table in BRAHMS – also from RDE files. Report design is covered in detail in the 

BRAHMS manual: https://herbaria.plants.ox.ac.uk/bol/content/software/v8/BRAHMS_Manual.pdf.  

This report example, included with the demo conifer database, introduces a number of features. These may look 

complex but the template only took a minutes to prepare. These features are described in detail in the manual. 

• Title band: printed once at the start. It includes a text box; a transparent image; the print date; and a line feature. 

• A Group Header band: this has a data source Species.FamilyName with a text box for the family name; and a total 

count of species printed per family. Group headers automatically sort entries based on the data source. 

• A Data Band: this has a data source set to the Species table and it has a text box for the species name (calculated 

HTML format); and the IUCN category. The IUCN category has conditional formatting to only print when non-null. 

This band has a Sort set on the species name. 

• A Data Band: this has a data source set to the Species Texts and it has a text box for the text title and the actual 

text. This band is set as a Master Component band relating to species. It has a filter set to only print records where 

the text title is “Conservation”. 

• A Page Footer band: this has a text box entry and also includes page number/page total. 

• A page Watermark with transparency set to 65%. 

 

• Select Taxa > Species. Select Tag > Clear tags > from records in the current grid. 

• In the filter row, add “acc” to Taxon Status and “Arau” to family. 

 

Setting filters in the main species table. 

• Select Tag > Tag All to tag all accepted species in the Auracariaceae. 

• Select Reports. Highlight the report “Species list with conservation data” and then choose Run. 

• To view or edit the report template, select Reports > Edit Template. 

As the report is “Shared”, other users logged into this database will also see this report template. 

https://herbaria.plants.ox.ac.uk/bol/content/software/v8/BRAHMS_Manual.pdf
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Task 26: Dynamic weblinks  

Weblink toolbar 

You can dynamically link your data records in any table to external websites as provided on the WebLinks toolbar. 

From BRAHMS v8.6 onwards, WebLink options are configurable, allowing you to add websites that you find most 

useful.  As an ornithologist, mycologist, plant taxonomist or a researcher with another interest, you can select 

personal Web Link connections as well as use sites that are shared across your BRAHMS project. 

 

An example of the weblinks toolbar, edited to show the required website links. 

Add your own weblinks 

Web Links can be configured to include search parameters that enable dynamic searching as you move through your 

data grid records. The Web Links editor on the Management menu includes options to select icons and toolbar text; add 

the URL with the appropriate search parameters utilizing any BRAHMS data field from the relevant table; set whether 

the link is personal or shared; choose the BRAHMS tables your weblinks are associated with; and set the order in which 

they appear. The ability to edit Web Links is permission controlled. 

In the following example, a dynamic link to INaturalist is added: 

• Select Management > Manage Weblinks and then New Link. 

• Enter the data as provided in the below screen. 
 

 
 
You can download the logo by searching for ‘iNaturalist’ logo. Then upload this to the Weblink Editor using the icon 
lookup. Keep the toolbar label as short as possible. The description is optional. The entry in the URL text field is:  
https://www.inaturalist.org/observations?place_id=any&taxon_name=<GenusName>+<SpeciesName> 
but you could also use e.g. 
https://www.inaturalist.org/observations/<Int06> where <Int06> is a BRAHMS custom field name holding the 
iNaturalist ID code.  
 
The field names inside <> are interpreted when you use the weblink, replacing these field names with the actual 
data values. You can ignore the Parameter Search and Property options as these are to help locate the correct 
search field names (which in this case we already have). 
 
Setting the availability using the multi-value lookup button is important as this dictates which tables the weblink 
option will be available for. Thus, if you want this toolbar to appear in the species table, make sure “Species” is 
added to the availability list. 

https://www.inaturalist.org/observations?place_id=any&taxon_name=%3cGenusName%3e+%3cSpeciesName
https://www.inaturalist.org/observations/%3cInt06
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• Select Taxa > Species to open the main species table.  

• Select WebLinks and choose your newly added weblink option. 

 

 

An example using the above added WebLink 

 

 

Another example using a dynamic link to GBIF. 
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Task 27: Creating your own database  

You can create a new and separate database project in the same SQLite file that includes the conifer demo. 

This is done with a few simple steps. When you are logged into the conifer demo database: 

• Select System > Manage Database Projects > New. 

• Enter the Project Title and any other details as prompted on the Manager form. 

• Select Save. Highlight your newly named project on the left and select Load Project. You will find that this 

project has no data. 

 

Adding a new database project to the same store as the conifer database. 

You can return to the Conifer demo database by selecting System > Manage Database Projects and then load the 

conifer project. Alternatively, you can select System > Sign Out and then log in again, selecting Conifers. 

Moving up to MSSQL Server or PostgreSQL 

In most cases, you will want to create an entirely separate data store which does not include the conifer demo 

database. As discussed below, for larger projects, especially multiple-user systems, you will use MSSQL Server 

or PostgreSQL as the data stores. 

This guide cannot cover these steps in detail – however the procedures to create such data store are covered 

in the main guide: https://herbaria.plants.ox.ac.uk/bol/content/software/v8/BRAHMS_Manual.pdf  

Please refer to the guide sections: 

• Data stores and databases. 

• Data Connections > Creating a PostgreSQL connection and database. 

• Data Connections > Creating a MSSQL Server connection and database. 

 

 

 

https://herbaria.plants.ox.ac.uk/bol/content/software/v8/BRAHMS_Manual.pdf
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Task 28: Some challenges  

 

1. Create a view in Collection Events to show the fields Tag, Collectors, Number, Collection Year, Full species name, 

Country and Major Area. Tag all collections from New Zealand that were collected in 1982. Map these using ArcGIS 

and export the collection data to Excel. 

 

 

2. Using the ArcGIS mapper, from the Collection Events table, draw a map of all conifer collections. Use the Draw Search 

Area and then Search Map Area tools for any region in West coast USA. In the updated data grid, use the Summary 

Tool to check the # collections per species in your selected area. Dock the summary tool next to the Map window. 

 

 

3. In the main species table, create a field view to show the fields as shown below. Set a filter to include taxa with IUCN 

status = CR OR VU. Tag these taxa and export to Excel. 
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